Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 26, 2026 - 23:45 EDT
Scheduled
On Saturday night, September 26, at midnight ET (12:00 AM Sunday, September 27), Payableapps will be unavailable for approximately 15 minutes while we upgrade our database.
Payable Forms will keep collecting submissions throughout the maintenance window, so you won't lose any form data. However, some submissions made during this window may be missing a Payable Order ID. If you notice any, simply run the Generate Missing Payable ID script and the IDs will be assigned.
We'll post an update here once maintenance is complete. Thanks for your patience while we make things faster and more reliable.
Posted Sep 24, 2026 - 10:40 EDT
This scheduled maintenance affected: Payable Checkout, Payable Forms Add-On and Infastructure (Cloudflare CDN/Cache, SendGrid API v3 (Email Provider), Google Cloud Platform Google Cloud SQL, Google Cloud Platform Google Compute Engine, Intercom Intercom APIs, Intercom Support Chats).